Knowledgebase & FAQ

When clicking on the Button icon within an Office application, nothing happens

Symptom

On the Microsoft Office application you click on the Check-in or Check-out icon but nothing happens.

Cause

This will occur if Microsoft Office .NET Programmability Support is not enabled (i.e. the Microsoft Office Primary Interop Assemblies are not installed).

To check if this is the case, perform the following:

(Method 1)

'.NET Programmability Support' is an optional feature of the various Microsoft Office components.

To check whether you have it installed, go to Start > Control Panel > Add/Remove Programs, highlight Microsoft Office and select ‘Change’ and then select 'Add or Remove Features'. For applicable Office component (ie. Excel, Outlook, PowerPoint, Word), confirm that the .NET Programmability Support is installed (ie. icon next to the option doesn’t contain a red cross), for example:

(Method 2)

Using Windows Explorer, navigate to your Windows folder (normally C:\Windows) and browse the ‘Assembly’ folder. Confirm that the following files exist:

  • Microsoft.Office.Interop.Excel
  • Microsoft.Office.Interop.Outlook
  • Microsoft.Office.Interop.PowerPoint
  • Microsoft.Office.Interop.Word

If these files are not present, it indicates that they are not installed and will cause the RecFind 6 Button not to function correctly.

Solution

If you do not have Microsoft Office .NET Programmability Support installed, you can either modify your Microsoft Office installation and enable the feature, or you can download and install the Microsoft Primary Interop Assemblies (PIAs) from Microsoft Downloads (Note: the PIAs can also be deployed via MSI if required).

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