3. What causes printing error 482 when trying to print reports or labels from RecFind?
Symptom
Attempts to print output from RecFind to a printer produces error 'Visual Basic runtime error 482'.
Cause
This error is a generic Visual BASIC run-time error meaning that
there was a Printer error. There are a number of possible causes for
this problem, including:
- unsupported network printer path
- improper configuration of printer driver
- missing barcode font
Solution
- Capture the printer port
There are known issues with network printer paths. Paths containing spaces and other "unusual" characters (excluding "_") may cause this error. Please check the
network path for the printer from within the Windows Control Panel.
To ascertain whether this is an issue, try capturing a port and
re-directing that port to the required network path. This will
enable the Microsoft Visual BASIC run-time to print to LPTx: but then allow the operating system to re-direct the output to the desired printer on the network.
-
For Windows 2000 Users:
For Windows 2000 and Microsoft Windows NT, you can use the following command from the command prompt:
net use lpt1 \\servername\printer /persistent:yes
This command maps the network printer to the local port LPT1.
Once you have mapped LTP1 to the network path, modify the
appropriate printer driver to printer to LPT1 (see screen below). If this is done, the printer on LPT1 is redirected when the user sends a print job to the printer on LPT1.
Additional information on printing to network ports in Windows 2000 can be found in the Microsoft Knowledge Base Article IDs:
-
For Windows 95/98 Users:
In the printer properties for your printer, select the
Capture Printer Port option (see below) and specify the
applicable network path. Please ensure that the "Print to the
following port" is set to LPT1: (see below).
- Check Printer Driver configuration options
Check the below settings in your printer driver:
- Print TrueType fonts as graphics = Enabled
- Print Quality = High
- Graphics Mode = Raster
NOTE: All printer drivers are slightly different in their terminology and some searching may be required to find these configuration options.
In some cases these options may not be configurable.
- Check that "3 of 9 barcode font is installed"
You may also ascertain if you experience any problems (re-)installing the "3 of 9 Barcode (Truetype)" font.
Check to see if your workstation has this font installed by
selecting Fonts from the Windows Control Panel and determining if it
is listed. If the font is not listed, select add and provide the RecFind directory on the server as the source. If it is
listed, delete the font and re-install it as describe previously.
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